¿PRESTASHOP 1.6.1 ES COMPATIBLE CON LA VERSIÓN DE PHP 7.2?

Buenas tardes hoy nos hemos encontrado unas cuantas sorpresas con la plataforma ecommerce Prestashop y una es la compatibilidad con las diferentes versiones de php.

La versión 1.6.1.1 funciona correctamente en con la versión de php 5.6. El problema viene cuando actualizamos la versión de php 7.0, 7.1 y finalmente con la versión php 7.2.

Con las versiones 7.1 y 7.2 las versiones de prestashop funcionan correctamente (El FrontOffice) El problema viene que hay algunos módulos que no son compatibles con estas versiones de php. o intentamos acceder al backoffice y nos da error 500…

Lo 1º Que tenemos que hacer si nos percatamos de algún error es: Poner la tienda en modo Debug para que nos arroje de donde viene el error y una vez que lo tengamos proceder. Para las versiones Prestashop 1.6. en adelante hasta la ultima versión de la 1.6.1… tenemos que hacerlo siguiendo estos pasos:

¿Como poner prestashop 1.6.1 en modo debug o modo fallos?

Antes de hacer nigún cambio en el archivo realizar una copia del mismo y guardarlo en un lugar seguro.

Tenemos que ir a la carpeta Config/Archivo: Denifes.inc.php y cambiar las lineas:

Modo Debug Prestashop para las versiones 1.6.1 en adelante hasta la última versión de la 1.6.1...

29 Cambiar de false a true.

34 Cambiar de off a on

Con esto ya estaría.

Ahora nos aparecería el error de porque no podemos conectarnos al backoffice.

A mi me ayudo mucho este mini tutorial os remito enlace ( https://stuffweb2016.wordpress.com/2018/08/26/prestashop-1-6-x-admin-error-500/ )

Os adjunto aquí que es lo que se hizo en este enlace que adjunto por si las moscas desaparece el link, aquí queda registrado:

Un error común que podría aparecer después de instalar prestashop es

Error grave: la declaración de AdminLoginControllerCore :: viewAccess () debe ser compatible con AdminControllerCore :: viewAccess ($ disable = false) en / var / www / prestashop / controllers / admin / AdminLoginController.php en línea  27

o, si no ha configurado prestashop en modo dev, obtendrá un error 500.

La forma de solucionar esto es simple:

  • vaya aROOT / controllers \ admin \ AdminLoginController.php
  • Al línea 153 tendrás que cambiar

función pública viewAccess ()  a   función pública viewAccess ($ disable = false)

A mi me funciono a las mil maravillas y tengo prestashop 1.6.18 Funcionado correctamente con la versión de PHP 7.2 cosa que con la versón 1.7.3.2 de prestashop no me funciono.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *